Recently I have noticed a lot of confusion among people when configuring and forming port-channels on Cisco IOS equipment. I had someone recently say “Just configure the trunking commands under the interfaces and it’ll work. Now, while this will work, it is more or less, a hack. A port-channel/etherchannel is a logical interface holding certain configuration parameters which will absorb into the physical interface configuration when you apply a physical interface into the “channel-group”. The following describes how I setup etherchannel successfully each time, every time:

interface port-channel 1
switchport trunk encap dot1
switchport mode trunk
switchport trunk native vlan - for those of us who don't use VLAN 1
no shut

interface gi1/0/1
priority-queue out
mls qos trust dscp
channel-group 1 mode on
no shut

interface gi2/0/1
priority-queue out
mls qos trust dscp
channel-group 1 mode on
no shut

interface gi3/0/1
priority-queue out
mls qos trust dscp
channel-group 1 mode on
no shut

This would be on a Cisco 3750X in a 3 switch stack. If you configure in this order the trunking commands will apply correctly and you’ll form your port-channel correctly.


Comments are closed.